Tuesday, October 09, 2007

Gnome My Foot

I have not been paying much attention to the (old) Gnome versus KDE debate until yesterday (I just assumed that Linus is nit-picking and brushed it off).

But after installing OpenSUSE 10.3 I realized that the API for the gtksourceview component has changed. In the process, a part that is important to me (source markers) was dropped. It is not a show-stopper or enough reason for me to part with Gnome, because for the time being I have got some options, and the GtkSourceView team will reintroduce the dropped features by version 2.22.

But I understand now how people get upset over dropped features and interface changes.

As always, Linus was right.

5 comments:

Jonner said...

not true. The new library is parallel-installable with the old one, so you can continue using it until version 2 regains the Source Marker API.

Jonner said...

ok, so I should have read the link in your post ("have got some options") since you apparently realize that the old version is still usable. So now I'm not sure I really understand your gripe. Yes, it's annoying that they didn't have time to get the Source Marker API in shape for the 2.0 release, but all decent distros will no doubt continue to package both versions so there shouldn't be any problem.

The Free Meme said...

I agree, and this is why, like I said, it is not a deal-breaker for me.

I just gained a better understanding of how these changes irritate people.

It is also a matter of what is installed as default, and how much effort is required from the users to figure out what is going on.

6:13 PM

The Free Meme said...

Oh, and I forgot the most important part.

In addition to spending time investigating the API changes I also have to make sure that I tell my users that now there is this dependency that they have to be aware of, and they have to need gtksourceview-1.0 and gtksourceviemm-1.0 in addition to the 2.0 counterparts. Painful.

The Free Meme said...

sudo rpm -Uvh ~/Desktop/gtksourceview-1.8.5-2.2.i586.rpm ~/Desktop/gtksourceview-devel-1.8.5-2.2.i586.rpm
root's password:
error: Failed dependencies:
gtksourceview >= 2.0.0 is needed by (installed) libgtksourceview-2_0-0-2.0.0-5.i586

sudo rpm -i ~/Desktop/gtksourceview-1.8.5-2.2.i586.rpm ~/Desktop/gtksourceview-devel-1.8.5-2.2.i586.rpm
package gtksourceview-2.0.0-5 (which is newer than gtksourceview-1.8.5-2.2) is already installed
package gtksourceview-devel-2.0.0-5 (which is newer than gtksourceview-devel-1.8.5-2.2) is already installed
file /usr/lib/libgtksourceview-1.0.so.0.0.0 from install of gtksourceview-1.8.5-2.2 conflicts with file from package gtksourceview18-1.8.5-16

Why do I have to care about this stuff, why? I just want to focus on MY code, okay?